Want to Join Us ?

you'll be able to discuss, share and send private messages.

How To Fix Steam Games Not Working

AUSTIN Aug 8, 2014

  1. AUSTIN

    Management Root

    So a lot of you seem to be getting the problem of your steam games not running after the last update. So this is a post that tells you how to fix this problem.


    If running: Windows XP/Vista/7
    • Completely exit from the Steam client.
    • Go to C:\Program Files\Steam (or the Steam directory that was specified during installation).
    • Locate ClientRegistry.blob and rename this file to ClientRegistryOld.blob.
    • Restart Steam to allow the file to be recreated.
    • Test the issue once more.

    If running: Mac OSX
    • Completely exit from the Steam client.
    • Go to /Users/[Username]/Library/Application Support/Steam
    • Locate ClientRegistry.blob and rename this file to ClientRegistryOld.blob.
    • Restart Steam to allow the file to be recreated.
    • Test the issue once more.
    Important:
    DO NOT DELETE the Old.blob!
     
    Last edited by a moderator: Aug 8, 2014
  2. Slice;3

    + 3 Regular

    All of my games still doesn't work,did what u said..But still doesn't work :/ Maybe you have any other suggestions? What or who could fix this?

    When i launch game or just press ''Play'' Button,nothing happends..Game doesn't launch,my avatar starts glowing like it says that i am in-game,but after a sec or 2..It's blueee again Q_Q And all of my games like that,doesn't work at allllllll...HELP!
     
  3. AUSTIN

    Management Root

    re-install steam.
     
  4. Slice;3

    + 3 Regular

    Ammiilla tried it,didn't work :/
     
  5. AUSTIN

    Management Root

    Do you guys get any error messages?
     
  6. Luke

    Owner Root Donor

    • Luke
    • Apr 11, 2014
    • 459
    • 235
    So wait, who's having a problem? Slice or Ammilla?
     
  7. Slice;3

    + 3 Regular

    Nope,im getting nothing..I just launch a game or press a play button,my avatar starts glowing for sec or 2 but nothing happens..

    And Luke, it's me and Ammiilla
     
  8. Slice;3

    + 3 Regular

  9. AUSTIN

    Management Root

  10. Slice;3

    + 3 Regular

    Not just Source games,all of my other games aswell ;-;
     
  11. Luke

    Owner Root Donor

    • Luke
    • Apr 11, 2014
    • 459
    • 235
    Sounds like a graphics card issue.
     
  12. [E2L] Ammiilla ^ω^

    The one and only

    its not...I've checked
     
  13. Luke

    Owner Root Donor

    • Luke
    • Apr 11, 2014
    • 459
    • 235
    The only thing I can think of that would most likely fix it is a reformat.
     
  14. SethosaurusRex

    Almost Important Operator

    Don't uninstall Steam; right click on your games, go to properties, and validate local game cache (or whatever it is).

    This usually fixes it, but if it doesn't, completely uninstall and reinstall your games, not Steam.
     
Top